What’s Vulnerable › Vulnerabilities
CVE-2025-71393: SurrealDB before 2.2.2 Memory Exhaustion via Nested Functions
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-29
- Weakness: CWE-674
Description
SurrealDB before 2.2.2 with scripting enabled fails to properly enforce recursion limits when native functions contain embedded JavaScript that issues new queries. Authenticated attackers can bypass the recursion limit by chaining native and JavaScript function calls to trigger infinite recursion and exhaust server memory.
Affected products
- surrealdb: before 2.0.5; from 2.1.0 before 2.1.5; from 2.2.0 before 2.2.2 — fixed in 2.0.5, 2.1.5, 2.2.2
- surrealdb: from 2.2.0 before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: surrealdb 2.0.5, 2.1.5, 2.2.2; surrealdb 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-m7rc-8w7m-r9qr
- https://www.vulncheck.com/advisories/surrealdb-before-memory-exhaustion-via-nested-functions
Get alerted when CVE-2025-71393 or the next vulnerability affects your stack