What’s Vulnerable › Vulnerabilities

CVE-2025-71395: SurrealDB before 2.2.2 Memory Exhaustion via string::replace

Description

SurrealDB versions before 2.2.2 contain a memory exhaustion vulnerability in the string::replace function that fails to restrict resulting string length when using regex patterns. An authenticated attacker can craft a malicious query to exhaust server memory through unbounded string allocations, causing denial of service.

Affected products

How to fix

Upgrade to a fixed version: surrealdb 2.0.5, 2.1.5, 2.2.2; surrealdb 2.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-71395 or the next vulnerability affects your stack