What’s Vulnerable › Vulnerabilities
CVE-2025-71396: SurrealDB before 2.2.2 Denial of Service via JavaScript Scripting
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-29
- Weakness: CWE-770
Description
SurrealDB before 2.0.5, 2.1.x before 2.1.5, and 2.2.x before 2.2.2 does not enforce a default execution-time limit on embedded JavaScript scripting functions when the scripting capability is explicitly enabled (via --allow-scripting or --allow-all). An authenticated attacker can submit long-running JavaScript functions to exhaust server resources and cause a denial of service. Scripting is disabled by default.
Affected products
- surrealdb: before 2.0.5; from 2.1.0 before 2.1.5; from 2.2.0 before 2.2.2 — fixed in 2.0.5, 2.1.5, 2.2.2
- surrealdb: from 2.2.0 before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: surrealdb 2.0.5, 2.1.5, 2.2.2; surrealdb 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-3824-qmfq-2qv7
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-javascript-scripting
Get alerted when CVE-2025-71396 or the next vulnerability affects your stack