What’s Vulnerable › Vulnerabilities
CVE-2025-71402: better-auth before 1.4.0 Session Revocation via Forged Cookie
- Severity: low (CVSS 2.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-06
- Weakness: CWE-347
Description
better-auth versions greater than 1.3.34 and before 1.4.0 contain a vulnerability in the multi-session plugin's /sign-out after-hook, which trusts raw multi-session cookies and forwards extracted values to internalAdapter.deleteSessions without verifying the cookie signature (e.g., via getSignedCookie). An attacker can supply a forged _multi-* cookie to trigger deletion of arbitrary session tokens.
Affected products
- better-auth: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: better-auth 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-wmjr-v86c-m9jj
- https://www.vulncheck.com/advisories/better-auth-before-session-revocation-via-forged-cookie
Get alerted when CVE-2025-71402 or the next vulnerability affects your stack