What’s Vulnerable › Vulnerabilities
CVE-2025-71403: better-auth before 1.1.20 Open Redirect via trustedOrigins Bypass
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-06
- Weakness: CWE-601
Description
better-auth versions before 1.1.20 contain a bypass vulnerability in trustedOrigins validation logic affecting absolute URLs and wildcard domains. Attackers can construct malicious callbackURL parameters that pass origin checks and trigger open redirects to steal sensitive tokens for account takeover.
Affected products
- better-auth: before 1.1.20 — fixed in 1.1.20
How to fix
Upgrade to a fixed version: better-auth 1.1.20. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-vp58-j275-797x
- https://www.vulncheck.com/advisories/better-auth-before-open-redirect-via-trustedorigins-bypass
Get alerted when CVE-2025-71403 or the next vulnerability affects your stack