What’s Vulnerable › Vulnerabilities
CVE-2025-71404: better-auth before 1.1.16 Reflected XSS via error parameter
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-06
- Weakness: CWE-79
Description
better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.
Affected products
- better-auth: before 1.1.16 — fixed in 1.1.16
How to fix
Upgrade to a fixed version: better-auth 1.1.16. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/commit/05ada0b79dbcac93cc04ceb79b23ca598d07830c
- https://github.com/better-auth/better-auth/security/advisories/GHSA-9x4v-xfq5-m8x5
- https://www.vulncheck.com/advisories/better-auth-before-reflected-xss-via-error-parameter
Get alerted when CVE-2025-71404 or the next vulnerability affects your stack