What’s Vulnerable › Vulnerabilities
CVE-2025-71406: Nokogiri updates packaged libxslt to v1.1.43 to resolve multiple CVEs
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-09-10
- Weakness: CWE-1395
Description
## Summary Nokogiri v1.18.4 upgrades its dependency libxslt to [v1.1.43](https://gitlab.gnome.org/GNOME/libxslt/-/releases/v1.1.43). libxslt v1.1.43 resolves: - CVE-2025-24855: Fix use-after-free of XPath context node - CVE-2024-55549: Fix UAF related to excluded namespaces ## Impact ### CVE-2025-24855 - "Use-after-free due to xsltEvalXPathStringNs leaking xpathCtxt->node" - MITRE has rated this 7.8 High CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H - Upstream report: https://gitlab.gnome.org/GNOME/libxslt/-/issues/128 - NVD entry: https://nvd.nist.gov/vuln/detail/CVE-2025-24855 ### CVE-2024-55549 - "Use-after-free related to excluded result prefixes" - MITRE has rated this 7.8 High CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H - Upstream report: https://gitlab.gnome.org/GNOME/libxslt/-/issues/127 - NVD entry: https://nvd.nist.gov/vuln/detail/CVE-2024-55549
Affected products
- Rubygems Nokogiri: before 1.18.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+177) — fixed in 1.18.4
How to fix
Upgrade to a fixed version: Rubygems Nokogiri 1.18.4. Check the vendor advisory for mitigations.
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-mrxw-mxhj-p664
- https://nvd.nist.gov/vuln/detail/CVE-2024-55549
- https://nvd.nist.gov/vuln/detail/CVE-2025-24855
- https://github.com/sparklemotion/nokogiri
- https://gitlab.gnome.org/GNOME/libxslt/-/issues/127
- https://gitlab.gnome.org/GNOME/libxslt/-/issues/128
Get alerted when CVE-2025-71406 or the next vulnerability affects your stack