What’s Vulnerable › Vulnerabilities
CVE-2025-71407: Nokogiri updates packaged libxml2 to 2.13.6 to resolve CVE-2025-24928 and CVE-2024-56171
- Severity: low (CVSS 3.0)
- Exploited in the wild: not listed in CISA KEV
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-09-10
- Weakness: CWE-121
Description
## Summary Nokogiri v1.18.3 upgrades its dependency libxml2 to [v2.13.6](https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.13.6). libxml2 v2.13.6 addresses: - CVE-2025-24928 - described at https://gitlab.gnome.org/GNOME/libxml2/-/issues/847 - CVE-2024-56171 - described at https://gitlab.gnome.org/GNOME/libxml2/-/issues/828 ## Impact ### CVE-2025-24928 Stack-buffer overflow is possible when reporting DTD validation errors if the input contains a long (~3kb) QName prefix. ### CVE-2024-56171 Use-after-free is possible during validation against untrusted XML Schemas (.xsd) and, potentially, validation of untrusted documents against trusted Schemas if they make use of `xsd:keyref` in combination with recursively defined types that have additional identity constraints.
Affected products
- Rubygems Nokogiri: before 1.18.3; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+176) — fixed in 1.18.3
How to fix
Upgrade to a fixed version: Rubygems Nokogiri 1.18.3. Check the vendor advisory for mitigations.
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-vvfq-8hwr-qm4m
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/GHSA-vvfq-8hwr-qm4m.yml
- https://github.com/sparklemotion/nokogiri
Get alerted when CVE-2025-71407 or the next vulnerability affects your stack