What’s Vulnerable › Vulnerabilities
CVE-2025-71418: PocketMine-MP before 5.25.2 Denial of Service via explode
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-14
- Weakness: CWE-400
Description
PocketMine-MP versions before 5.25.2 fail to limit the explode() function in packet parsing, allowing malicious clients to waste server resources. Attackers can send crafted packets with excessive delimiters to consume CPU and memory through sign editing, JWT parsing, and command parsing endpoints.
Affected products
- pmmp PocketMine-MP: before 5.25.2 — fixed in 5.25.2
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 5.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/d0d84d4c5195fb0a68ea7725424fda63b85cd831
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g274-c6jj-h78p
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.25.2-denial-of-service-via-explode
Get alerted when CVE-2025-71418 or the next vulnerability affects your stack