What’s Vulnerable › Vulnerabilities
CVE-2025-71419: UVdesk core-framework before 1.1.7 Stored XSS via SwiftMailer
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-10-14
- Weakness: CWE-79
Description
UVdesk core-framework before 1.1.7 contains a stored cross-site scripting vulnerability in the SwiftMailer configuration identifier parameter of the createMailerConfiguration action. Attackers with ROLE_AGENT can inject malicious script into the identifier field, which is persisted and executed when other members access the configuration update page.
Affected products
- uvdesk community-skeleton: before 1.1.8 — fixed in 1.1.8
- uvdesk core-framework: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: uvdesk community-skeleton 1.1.8; uvdesk core-framework 1.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/uvdesk/community-skeleton/releases/tag/v1.1.8
- https://github.com/uvdesk/core-framework
- https://github.com/uvdesk/core-framework/blob/v1.1.6/Controller/SwiftMailer.php#L38-L46
- https://github.com/uvdesk/core-framework/blob/v1.1.6/Resources/views/SwiftMailer/manageConfigurations.html.twig#L324
- https://github.com/uvdesk/core-framework/commit/e5e92d1f5bdb24d1b96751213fb427035736371f
- https://github.com/uvdesk/core-framework/releases/tag/v1.1.7
- https://hackmd.io/@leediay/B1Cz5voFGg
- https://www.vulncheck.com/advisories/uvdesk-core-framework-before-1.1.7-stored-xss-via-swiftmailer
Get alerted when CVE-2025-71419 or the next vulnerability affects your stack