What’s Vulnerable › Vulnerabilities
CVE-2025-71421: UVdesk core-framework before 1.1.7 Privilege Escalation via editAgent
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-10-14
- Weakness: CWE-269
Description
UVdesk core-framework before 1.1.7 contains an improper privilege management vulnerability in the editAgent endpoint that allows agents with agent-management privilege to escalate their own role to administrator. Attackers can submit their own account identifier with a role parameter set to ROLE_ADMIN to gain full administrative control over agents, tickets, and mail configuration.
Affected products
- uvdesk community-skeleton: before 1.1.8 — fixed in 1.1.8
- uvdesk core-framework: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: uvdesk community-skeleton 1.1.8; uvdesk core-framework 1.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/uvdesk/community-skeleton/releases/tag/v1.1.8
- https://github.com/uvdesk/core-framework
- https://github.com/uvdesk/core-framework/blob/v1.1.6/Controller/Account.php#L278-L282
- https://github.com/uvdesk/core-framework/commit/b8bcdc503659f9d5c5cd73627cfc5d45508b9a55
- https://github.com/uvdesk/core-framework/releases/tag/v1.1.7
- https://hackmd.io/@leediay/B1Cz5voFGg
- https://www.vulncheck.com/advisories/uvdesk-core-framework-before-1.1.7-privilege-escalation-via-editagent
Get alerted when CVE-2025-71421 or the next vulnerability affects your stack