What’s Vulnerable › Vulnerabilities
CVE-2025-71431: Frappe before 15.86.0 LDAP Injection via Unsanitized Endpoint Parameters
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-19
- Weakness: CWE-90
Description
Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection vulnerability because certain endpoints do not sanitize user-supplied parameters before using them in LDAP queries. Attackers can supply crafted LDAP filter syntax through these parameters to alter the resulting directory queries.
Affected products
- frappe: before 14.99.2; from 15.0.0 before 15.86.0 — fixed in 14.99.2, 15.86.0
How to fix
Upgrade to a fixed version: frappe 14.99.2, 15.86.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-qrq5-v93p-8xhw
- https://www.vulncheck.com/advisories/frappe-before-15.86.0-ldap-injection-via-unsanitized-endpoint-parameters
Get alerted when CVE-2025-71431 or the next vulnerability affects your stack