What’s Vulnerable › Vulnerabilities
CVE-2025-71432: Frappe ERPNext before 15.83.0 Reflected XSS Leading to Account Takeover
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-19
- Weakness: CWE-79
Description
Frappe ERPNext before 14.92.1 and 15.x before 15.83.0 contains a reflected cross-site scripting vulnerability due to missing input validation on a certain page, allowing arbitrary JavaScript to execute in authenticated sessions. Remote attackers can lure a logged-in user into opening a crafted URL to run injected script and take over the victim's account.
Affected products
- frappe erpnext: before 14.92.1; from 15.0.0 before 15.83.0 — fixed in 14.92.1, 15.83.0
How to fix
Upgrade to a fixed version: frappe erpnext 14.92.1, 15.83.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-f74g-9wxg-j83p
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.83.0-reflected-xss-leading-to-account-takeover
Get alerted when CVE-2025-71432 or the next vulnerability affects your stack