What’s Vulnerable › Vulnerabilities
CVE-2025-71435: Coder before 2.23.0 Session Expiration Bypass via OIDC Without Refresh Token
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-24
- Weakness: CWE-613
Description
Coder before 2.23.0 contains a session expiration bypass vulnerability that allows authenticated users to retain access after OIDC token expiry when no refresh token is issued. Users can keep their APIKey cookie active through regular use, extending it every 24 hours to access Coder indefinitely after losing OIDC authorization.
Affected products
- coder: before 2.23.0 — fixed in 2.23.0
How to fix
Upgrade to a fixed version: coder 2.23.0. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/security/advisories/GHSA-3rw9-wmc8-8948
- https://www.vulncheck.com/advisories/coder-before-2.23.0-session-expiration-bypass-via-oidc-without-refresh-token
Get alerted when CVE-2025-71435 or the next vulnerability affects your stack