What’s Vulnerable › Vulnerabilities
CVE-2025-7204: Exposure of password hashes via API responses in ConnectWise PSA
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-09 · updated 2026-06-17
- Weakness: CWE-201
Description
In ConnectWise PSA versions older than 2025.9, a vulnerability exists where authenticated users could gain access to sensitive user information. Specific API requests were found to return an overly verbose user object, which included encrypted password hashes for other users. Authenticated users could then retrieve these hashes. An attacker or privileged user could then use these exposed hashes to conduct offline brute-force or dictionary attacks. Such attacks could lead to credential compromise, allowing unauthorized access to accounts, and potentially privilege escalation within the system.
Affected products
- ConnectWise Professional Service Automation: before 2025.9 — fixed in 2025.9
How to fix
Upgrade to a fixed version: ConnectWise Professional Service Automation 2025.9. Check the vendor advisory for mitigations.
References
- https://www.connectwise.com/company/trust/security-bulletins/connectwise-psa-2025.9-security-fix
- https://www.themissinglink.com.au/security-advisories/cve-2025-7204
Get alerted when CVE-2025-7204 or the next vulnerability affects your stack