What’s Vulnerable › Vulnerabilities
CVE-2025-7207: mruby nregs codegen.c scope_new heap-based overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-09 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability, which was classified as problematic, was found in mruby up to 3.4.0-rc2. Affected is the function scope_new of the file mrbgems/mruby-compiler/core/codegen.c of the component nregs Handler. The manipulation leads to heap-based buffer overflow. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The name of the patch is 1fdd96104180cc0fb5d3cb086b05ab6458911bb9. It is recommended to apply a patch to fix this issue.
Affected products
- mruby/mruby: before 3.4.0; 3.4.0-rc, 3.4.0-rc2 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: mruby/mruby 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/mruby/mruby/commit/1fdd96104180cc0fb5d3cb086b05ab6458911bb9
- https://github.com/mruby/mruby/issues/6509
- https://github.com/mruby/mruby/issues/6509#event-17145516649
- https://github.com/user-attachments/files/19619499/mruby_crash.txt
- https://vuldb.com/?ctiid.315156
- https://vuldb.com/?id.315156
- https://vuldb.com/?submit.607683
- https://github.com/mruby/mruby/issues/6509
Get alerted when CVE-2025-7207 or the next vulnerability affects your stack