What’s Vulnerable › Vulnerabilities
CVE-2025-7339: on-headers vulnerable to http response header manipulation
- Severity: low (CVSS 3.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-241
Description
on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()`. Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.
Affected products
- Npm On-Headers: before 1.1.0 — fixed in 1.1.0
- jshttp on-headers: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Npm On-Headers 1.1.0; jshttp on-headers 1.1.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/morgan/issues/315
- https://github.com/jshttp/on-headers/commit/c6e384908c9c6127d18831d16ab0bd96e1231867
- https://github.com/jshttp/on-headers/issues/15
- https://github.com/jshttp/on-headers/security/advisories/GHSA-76c9-3jph-rj3q
Get alerted when CVE-2025-7339 or the next vulnerability affects your stack