What’s Vulnerable › Vulnerabilities
CVE-2025-7382
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability in WebAdmin of Sophos Firewall versions older than 21.0 MR2 (21.0.2) can lead to adjacent attackers achieving pre-auth code execution on High Availability (HA) auxiliary devices, if OTP authentication for the admin user is enabled.
Affected products
- Sophos Firewall: before 21.0.2 — fixed in 21.0.2
How to fix
Upgrade to a fixed version: Sophos Firewall 21.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7382 or the next vulnerability affects your stack