What’s Vulnerable › Vulnerabilities
CVE-2025-7388: Authenticated Command Injection via configuration parameter manipulation in exposed RMI interface
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-06-17
- Weakness: CWE-77
Description
It was possible to perform Remote Command Execution (RCE) via Java RMI interface in the OpenEdge AdminServer, allowing authenticated users to inject and execute OS commands under the delegated authority of the AdminServer process. An RMI interface permitted manipulation of a configuration property with inadequate input validation leading to OS command injection.
Affected products
- Progress Software Corporation OpenEdge: from OpenEdge 12.2.0 before 12.2.18; from OpenEdge 12.8.0 before 12.8.8 — fixed in 12.2.18, 12.8.8
How to fix
Upgrade to a fixed version: Progress Software Corporation OpenEdge 12.2.18, 12.8.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7388 or the next vulnerability affects your stack