What’s Vulnerable › Vulnerabilities
CVE-2025-7442: WPGYM - Wordpress Gym Management System < 67.8.0 - Unauthenticated SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-89
Description
The WPGYM - Wordpress Gym Management System plugin for WordPress is vulnerable to SQL Injection via several parameters in the MJ_gmgt_delete_class_limit_for_member, MJ_gmgt_get_yearly_income_expense, MJ_gmgt_get_monthly_income_expense, MJ_gmgt_add_class_limit, MJ_gmgt_view_meeting_detail, and MJ_gmgt_create_meeting functions in all versions up to 67.8.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- dasinfomedia WPGYM - Wordpress Gym Management System: before 67.8.0 — fixed in 67.8.0
How to fix
Upgrade to a fixed version: dasinfomedia WPGYM - Wordpress Gym Management System 67.8.0. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/-wpgym-wordpress-gym-management-system/13352964?s_rank=2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e52289fe-9a38-4ebf-b24a-034768fa56b7?source=cve
Get alerted when CVE-2025-7442 or the next vulnerability affects your stack