What’s Vulnerable › Vulnerabilities
CVE-2025-7504: Friends 3.5.1 - Authenticated (Subscriber+) PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-12 · updated 2026-06-17
- Weakness: CWE-502
Description
The Friends plugin for WordPress is vulnerable to PHP Object Injection in version 3.5.1 via deserialization of untrusted input of the query_vars parameter This makes it possible for authenticated attackers, with subscriber-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. This requires access to the sites SALT_NONCE and and SALT_KEY to exploit.
Affected products
- akirk Friends: before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: akirk Friends 3.5.2. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1K-_AcDk9BhUa0kSQ_M-UUnLgmnYJTA0l/view
- https://github.com/akirk/friends/pull/537
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3306684%40friends&new=3306684%40friends&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/friends/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cf91d75e-cef4-4154-aa16-6ca96db9c5bb?source=cve
Get alerted when CVE-2025-7504 or the next vulnerability affects your stack