What’s Vulnerable › Vulnerabilities
CVE-2025-7691: Privilege Defined With Unsafe Actions in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-26 · updated 2026-10-19
- Weakness: CWE-267
Description
A privilege escalation issue has been discovered in GitLab EE affecting all versions from 16.6 prior to 18.2.7, 18.3 prior to 18.3.3, and 18.4 prior to 18.4.1 that could have allowed a developer with specific group management permissions to escalate their privileges and obtain unauthorized access to additional system capabilities.
Affected products
- GitLab: from 16.6.0 before 18.2.7; from 18.3.0 before 18.3.3; 18.4.0 — fixed in 18.2.7, 18.3.3
How to fix
Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7691 or the next vulnerability affects your stack