What’s Vulnerable › Vulnerabilities
CVE-2025-7694: Woffice Core <= 5.4.26 - Authenticated (Contributor+) Arbitrary File Deletion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-02 · updated 2026-06-17
- Weakness: CWE-22
Description
The Woffice Core plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the woffice_file_manager_delete() function in all versions up to, and including, 5.4.26. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Affected products
- WofficeIO Woffice Core: before 5.4.27 — fixed in 5.4.27
How to fix
Upgrade to a fixed version: WofficeIO Woffice Core 5.4.27. Check the vendor advisory for mitigations.
References
- https://hub.woffice.io/woffice/changelog
- https://themeforest.net/item/woffice-intranetextranet-wordpress-theme/11671924
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41a362cf-e27e-436a-85f1-7c48e2e098eb?source=cve
Get alerted when CVE-2025-7694 or the next vulnerability affects your stack