What’s Vulnerable › Vulnerabilities
CVE-2025-7715: Block Attributes - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-090
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Block Attributes allows Cross-Site Scripting (XSS).This issue affects Block Attributes: from 0.0.0 before 1.1.0, from 2.0.0 before 2.0.1.
Affected products
- Drupal Block Attributes: from 7.x-1.x-dev before 8.x-1.1; 2.0.0 — fixed in 8.x-1.1
How to fix
Upgrade to a fixed version: Drupal Block Attributes 8.x-1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7715 or the next vulnerability affects your stack