What’s Vulnerable › Vulnerabilities
CVE-2025-7724: Unauthenticated command injection on VIGI NVR1104H-4P V1 and VIGI NVR2016H-16MP V2
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-22 · updated 2026-06-17
- Weakness: CWE-78
Description
An unauthenticated OS command injection vulnerability exists in VIGI NVR1104H-4P V1 and VIGI NVR2016H-16MP V2.This issue affects VIGI NVR1104H-4P V1: before 1.1.5 Build 250518; VIGI NVR2016H-16MP V2: before 1.3.1 Build 250407.
Affected products
- TP-Link Systems Inc. VIGI NVR1104H-4P V1: before 1.1.5 Build 250518 — fixed in 1.1.5 Build 250518
- TP-Link Systems Inc. VIGI NVR2016H-16MP V2: before 1.3.1 Build 250407 — fixed in 1.3.1 Build 250407
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. VIGI NVR1104H-4P V1 1.1.5 Build 250518; TP-Link Systems Inc. VIGI NVR2016H-16MP V2 1.3.1 Build 250407. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/jp/support/download/vigi-nvr1104h-4p/#Firmware
- https://www.tp-link.com/jp/support/download/vigi-nvr2016h-16mp/#Firmware
- https://www.tp-link.com/us/support/faq/4547/
Get alerted when CVE-2025-7724 or the next vulnerability affects your stack