What’s Vulnerable › Vulnerabilities

CVE-2025-7736: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.9 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated attacker to bypass access control restrictions and view GitLab Pages content intended only for project members by authenticating through OAuth providers.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-7736 or the next vulnerability affects your stack