What’s Vulnerable › Vulnerabilities
CVE-2025-7759: thinkgem JeeSite UEditor Image Grabber ActionEnter.java server-side request forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability was identified in thinkgem JeeSite up to 5.12.0. This vulnerability affects unknown code of the file modules/core/src/main/java/com/jeesite/common/ueditor/ActionEnter.java of the component UEditor Image Grabber. Such manipulation of the argument Source leads to server-side request forgery. The attack may be performed from remote. The exploit is publicly available and might be used. The name of the patch is 1c5e49b0818037452148e0f8ff69ed04cb8fefdc. It is advisable to implement a patch to correct this issue.
Affected products
- thinkgem JeeSite: before 5.12.1 — fixed in 5.12.1
How to fix
Upgrade to a fixed version: thinkgem JeeSite 5.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/MentalityXt/jeesite_ssrf/tree/main
- https://github.com/thinkgem/jeesite5/commit/1c5e49b0818037452148e0f8ff69ed04cb8fefdc
- https://github.com/thinkgem/jeesite5/issues/27
- https://vuldb.com/?ctiid.316749
- https://vuldb.com/?id.316749
- https://vuldb.com/?submit.615769
- https://github.com/thinkgem/jeesite5/issues/27
Get alerted when CVE-2025-7759 or the next vulnerability affects your stack