What’s Vulnerable › Vulnerabilities
CVE-2025-7776: Memory overflow vulnerability leading to unpredictable or erroneous behavior and Denial of Service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-26 · updated 2026-06-17
- Weakness: CWE-119
Description
Memory overflow vulnerability leading to unpredictable or erroneous behavior and Denial of Service in NetScaler ADC and NetScaler Gateway when NetScaler is configured as a Gateway (VPN virtual server, ICA Proxy, CVPN, RDP Proxy) with PCoIP Profile bounded to it
Summary
CVE-2025-7776 is a critical (CVSS 9.8) memory overflow in Citrix NetScaler ADC and NetScaler Gateway that causes unpredictable or erroneous behavior and denial of service. It affects appliances configured as a Gateway (VPN virtual server, ICA Proxy, CVPN, or RDP Proxy) with a PCoIP Profile bound to it. There is no known exploitation in CISA KEV or SSVC, though EPSS estimates a 9.1% chance of exploitation within 30 days. Apply the fixed versions: NetScaler ADC 12.1-55.330, 13.1-37.241, 13.1-59.22, or 14.1-47.48; NetScaler Gateway 13.1-59.22 or 14.1-47.48.
تُعد CVE-2025-7776 ثغرة فيضان ذاكرة حرجة (CVSS 9.8) في Citrix NetScaler ADC وNetScaler Gateway، وتؤدي إلى سلوك غير متوقع أو خاطئ وإلى حجب الخدمة. تصيب الأجهزة المهيأة كـ Gateway (VPN virtual server أو ICA Proxy أو CVPN أو RDP Proxy) مع ربط PCoIP Profile بها. لا يوجد استغلال معروف وفق CISA KEV أو SSVC، لكن EPSS يقدّر احتمال الاستغلال خلال 30 يوماً بنسبة 9.1%. طبّق الإصدارات المُصلحة: NetScaler ADC 12.1-55.330 أو 13.1-37.241 أو 13.1-59.22 أو 14.1-47.48؛ وNetScaler Gateway 13.1-59.22 أو 14.1-47.48.
Affected products
- Citrix NetScaler ADC: from 13.1 before 13.1-59.22; from 14.1 before 14.1-47.48 — fixed in 13.1-59.22, 14.1-47.48
- Citrix Netscaler Application Delivery Controller Fips: from 12.1 before 12.1-55.330; from 13.1 before 13.1-37.241 — fixed in 12.1-55.330, 13.1-37.241
- Citrix Netscaler Application Delivery Controller Ndcpp: from 12.1 before 12.1-55.330; from 13.1 before 13.1-37.241 — fixed in 12.1-55.330, 13.1-37.241
- Citrix NetScaler Gateway: from 13.1 before 13.1-59.22; from 14.1 before 14.1-47.48 — fixed in 13.1-59.22, 14.1-47.48
- NetScaler ADC: from 14.1 before 47.48; from 13.1 before 59.22; from 13.1 FIPS and NDcPP before 37.241; from 12.1 FIPS and NDcPP before 55.330 — fixed in 47.48, 59.22, 37.241, 55.330
- NetScaler Gateway: from 14.1 before 47.48; from 13.1 before 59.22; from 13.1 FIPS and NDcPP before 37.241; from 12.1 FIPS and NDcPP before 55.330 — fixed in 47.48, 59.22, 37.241, 55.330
How to fix
Upgrade to a fixed version: Citrix NetScaler ADC 13.1-59.22, 14.1-47.48; Citrix Netscaler Application Delivery Controller Fips 12.1-55.330, 13.1-37.241; Citrix Netscaler Application Delivery Controller Ndcpp 12.1-55.330, 13.1-37.241; Citrix NetScaler Gateway 13.1-59.22, 14.1-47.48; NetScaler ADC 47.48, 59.22, 37.241, 55.330; NetScaler Gateway 47.48, 59.22, 37.241, 55.330. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7776 or the next vulnerability affects your stack