What’s Vulnerable › Vulnerabilities
CVE-2025-7783: Usage of unsafe random function in form-data for choosing boundary
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-18 · updated 2026-06-17
- Weakness: CWE-330
Description
Use of Insufficiently Random Values vulnerability in form-data allows HTTP Parameter Pollution (HPP). This vulnerability is associated with program files lib/form_data.Js. This issue affects form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.
Affected products
- Npm Form-Data: before 2.5.4; from 3.0.0 before 3.0.4; from 4.0.0 before 4.0.4 — fixed in 2.5.4, 3.0.4, 4.0.4
How to fix
Upgrade to a fixed version: Npm Form-Data 2.5.4, 3.0.4, 4.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/form-data/form-data/commit/3d1723080e6577a66f17f163ecd345a21d8d0fd0
- https://github.com/form-data/form-data/security/advisories/GHSA-fjxv-7rqg-78g4
- https://lists.debian.org/debian-lts-announce/2025/07/msg00023.html
- https://github.com/form-data/form-data/security/advisories/GHSA-fjxv-7rqg-78g4
Get alerted when CVE-2025-7783 or the next vulnerability affects your stack