What’s Vulnerable › Vulnerabilities
CVE-2025-7808: WP Shopify < 1.5.4 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Shopify WordPress plugin before 1.5.4 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- WP Shopify: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: WP Shopify 1.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7808 or the next vulnerability affects your stack