What’s Vulnerable › Vulnerabilities
CVE-2025-8014: Allocation of Resources Without Limits or Throttling in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-27 · updated 2026-10-19
- Weakness: CWE-770
Description
Denial of Service issue in GraphQL endpoints in Gitlab EE/CE affecting all versions from 11.10 prior to 18.2.7, 18.3 prior to 18.3.3, and 18.4 prior to 18.4.1 allows unauthenticated users to potentially bypass query complexity limits leading to resource exhaustion and service disruption.
Affected products
- GitLab: from 11.10.0 before 18.2.7; from 18.3.0 before 18.3.3; 18.4.0 — fixed in 18.2.7, 18.3.3
How to fix
Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8014 or the next vulnerability affects your stack