What’s Vulnerable › Vulnerabilities
CVE-2025-8032: XSLT documents could bypass CSP
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-22 · updated 2026-10-05
- Weakness: CWE-693
Description
XSLT document loading did not correctly propagate the source document which bypassed its CSP. This vulnerability was fixed in Firefox 141, Firefox ESR 128.13, Firefox ESR 140.1, Thunderbird 141, Thunderbird 128.13, and Thunderbird 140.1.
Affected products
- Mozilla Firefox: before 128.13.0; before 141.0; from 140.0 before 140.1.0 — fixed in 128.13.0, 140.1.0, 141.0
- Mozilla Thunderbird: before 128.13.0; before 141.0; from 140.0 before 140.1.0 — fixed in 128.13.0, 140.1.0, 141.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.13.0, 140.1.0, 141.0; Mozilla Thunderbird 128.13.0, 140.1.0, 141.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1974407
- https://www.mozilla.org/security/advisories/mfsa2025-56/
- https://www.mozilla.org/security/advisories/mfsa2025-58/
- https://www.mozilla.org/security/advisories/mfsa2025-59/
- https://www.mozilla.org/security/advisories/mfsa2025-61/
- https://www.mozilla.org/security/advisories/mfsa2025-62/
- https://www.mozilla.org/security/advisories/mfsa2025-63/
- https://lists.debian.org/debian-lts-announce/2025/07/msg00016.html
Get alerted when CVE-2025-8032 or the next vulnerability affects your stack