What’s Vulnerable › Vulnerabilities
CVE-2025-8046: Injection Guard < 1.2.8 - Reflected XSS via $_SERVER['REQUEST_URI']
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Injection Guard WordPress plugin before 1.2.8 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- Injection Guard: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: Injection Guard 1.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14a53525-8c08-472d-bae4-b3f14368b802/
- https://wpscan.com/vulnerability/14a53525-8c08-472d-bae4-b3f14368b802/
Get alerted when CVE-2025-8046 or the next vulnerability affects your stack