What’s Vulnerable › Vulnerabilities
CVE-2025-8067: Udisks: out-of-bounds read in udisks daemon
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-28 · updated 2026-09-26
- Weakness: CWE-125
Description
A flaw was found in the Udisks daemon, where it allows unprivileged users to create loop devices using the D-BUS system. This is achieved via the loop device handler, which handles requests sent through the D-BUS interface. As two of the parameters of this handle, it receives the file descriptor list and index specifying the file where the loop device should be backed. The function itself validates the index value to ensure it isn't bigger than the maximum value allowed. However, it fails to validate the lower bound, allowing the index parameter to be a negative value. Under these circumstances, an attacker can cause the UDisks daemon to crash or perform a local privilege escalation by gaining access to files owned by privileged users.
Affected products
- Red Hat Enterprise Linux 10: all versions — fixed in 0:2.10.90-5.el10_0.1
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:2.8.4-1.el7_9.2
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.9.0-16.el8_10.1
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 0:2.8.3-2.el8_2.1
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:2.9.0-6.el8_4.1
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 0:2.9.0-6.el8_4.1
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:2.9.0-9.el8_6.1
- Red Hat Enterprise Linux 8.6 Telecommunications Update Service: all versions — fixed in 0:2.9.0-9.el8_6.1
- Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: all versions — fixed in 0:2.9.0-9.el8_6.1
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:2.9.0-13.el8_8.1
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 0:2.9.0-13.el8_8.1
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.9.4-11.el9_6.1
- Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: all versions — fixed in 0:2.9.4-3.el9_0.2
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:2.9.4-7.el9_2.2
- Red Hat Enterprise Linux 9.4 Extended Update Support: all versions — fixed in 0:2.9.4-10.el9_4.2
- storaged-project udisks: before 2.10.2; from 2.10.3 before 2.10.91 — fixed in 2.10.2, 2.10.91
How to fix
Upgrade to a fixed version: Red Hat Enterprise Linux 10 0:2.10.90-5.el10_0.1; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:2.8.4-1.el7_9.2; Red Hat Enterprise Linux 8 0:2.9.0-16.el8_10.1; Red Hat Enterprise Linux 8.2 Advanced Update Support 0:2.8.3-2.el8_2.1; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:2.9.0-6.el8_4.1; Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On 0:2.9.0-6.el8_4.1; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:2.9.0-9.el8_6.1; Red Hat Enterprise Linux 8.6 Telecommunications Update Service 0:2.9.0-9.el8_6.1; Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions 0:2.9.0-9.el8_6.1; Red Hat Enterprise Linux 8.8 Telecommunications Update Service 0:2.9.0-13.el8_8.1; Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions 0:2.9.0-13.el8_8.1; Red Hat Enterprise Linux 9 0:2.9.4-11.el9_6.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:15017
- https://access.redhat.com/errata/RHSA-2025:15018
- https://access.redhat.com/errata/RHSA-2025:15020
- https://access.redhat.com/errata/RHSA-2025:15956
- https://access.redhat.com/errata/RHSA-2025:16021
- https://access.redhat.com/errata/RHSA-2025:16090
- https://access.redhat.com/errata/RHSA-2025:16106
- https://access.redhat.com/errata/RHSA-2025:16121
- https://access.redhat.com/errata/RHSA-2025:16122
- https://access.redhat.com/errata/RHSA-2025:16125
- https://access.redhat.com/errata/RHSA-2025:16130
- https://access.redhat.com/security/cve/CVE-2025-8067
Get alerted when CVE-2025-8067 or the next vulnerability affects your stack