What’s Vulnerable › Vulnerabilities
CVE-2025-8068: HT Mega – Absolute Addons For Elementor <= 2.9.1 - Improper Authorization to Authenticated (Contributor+) Limited Administrator Actions
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-31 · updated 2026-06-17
- Weakness: CWE-863
Description
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to unauthorized modification and loss of data due to an improper capability check on the 'ajax_trash_templates' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary attachment files, and move arbitrary posts, pages, and templates to the Trash.
Affected products
- devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder: before 2.9.2 — fixed in 2.9.2
How to fix
Upgrade to a fixed version: devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.9.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ht-mega-for-elementor/tags/2.9.0/admin/include/class.theme-builder.php#L625
- https://plugins.trac.wordpress.org/changeset/3336533/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9cf6dae-572f-4eaa-8e8a-bca9e74fe738?source=cve
Get alerted when CVE-2025-8068 or the next vulnerability affects your stack