What’s Vulnerable › Vulnerabilities
CVE-2025-8081: Elementor <= 3.30.2 - Authenticated (Administrator+) Arbitrary File Read via Image Import
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-22
Description
The Elementor plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 3.30.2 via the Import_Images::import() function due to insufficient controls on the filename specified. This makes it possible for authenticated attackers, with administrator-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Affected products
- Elementor Website Builder: before 3.30.3 — fixed in 3.30.3
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.30.3. Check the vendor advisory for mitigations.
References
- https://github.com/elementor/elementor/commit/6af3551ee4213fb4003338743e22f41aa2a09c01
- https://plugins.trac.wordpress.org/browser/elementor/tags/3.30.2/includes/template-library/classes/class-import-images.php#L111
- https://plugins.trac.wordpress.org/changeset/3332233/elementor/trunk/includes/template-library/classes/class-import-images.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/13929b51-b32e-401c-a642-49f7cd2d07bf?source=cve
Get alerted when CVE-2025-8081 or the next vulnerability affects your stack