What’s Vulnerable › Vulnerabilities
CVE-2025-8085: Ditty < 3.1.58 - Unauthenticated SSRF
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-08 · updated 2026-09-30
- Weakness: CWE-918
Description
The Ditty WordPress plugin before 3.1.58 lacks authorization and authentication for requests to its displayItems endpoint, allowing unauthenticated visitors to make requests to arbitrary URLs.
Affected products
- Ditty: before 3.1.58 — fixed in 3.1.58
How to fix
Upgrade to a fixed version: Ditty 3.1.58. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8085 or the next vulnerability affects your stack