What’s Vulnerable › Vulnerabilities

CVE-2025-8099: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.8 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions, could have allowed an unauthenticated user to cause denial of service by sending repeated GraphQL queries.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.6.6, 18.7.4, 18.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-8099 or the next vulnerability affects your stack