What’s Vulnerable › Vulnerabilities
CVE-2025-8107
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-24 · updated 2026-06-17
- Weakness: CWE-269
Description
In OceanBase's Oracle tenant mode, a malicious user with specific privileges can achieve privilege escalation to SYS-level access by executing carefully crafted commands. This vulnerability only affects OceanBase tenants in Oracle mode. Tenants in MySQL mode are unaffected.
Affected products
- OB OceanBase Server: from 3.2.4.x before 3.2.4.8; from 4.2.1 x before 4.2.1.10; from 4.2.x before 4.2.5; from 4.3.3.x before 4.3.3.2 — fixed in 3.2.4.8, 4.2.1.10, 4.2.5, 4.3.3.2
How to fix
Upgrade to a fixed version: OB OceanBase Server 3.2.4.8, 4.2.1.10, 4.2.5, 4.3.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8107 or the next vulnerability affects your stack