What’s Vulnerable › Vulnerabilities
CVE-2025-8133: yanyutao0402 ChanCMS gather.js getArticle server-side request forgery
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-25 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability classified as critical has been found in yanyutao0402 ChanCMS up to 3.1.2. This affects the function getArticle of the file app/modules/api/service/gather.js. The manipulation of the argument targetUrl leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.3 is able to address this issue. The identifier of the patch is 3ef58a50e8b3c427b03c8cf3c9e19a79aa809be6. It is recommended to upgrade the affected component.
Affected products
- yanyutao0402 ChanCMS: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: yanyutao0402 ChanCMS 3.1.3. Check the vendor advisory for mitigations.
References
- https://gitee.com/yanyutao0402/ChanCMS/commit/3ef58a50e8b3c427b03c8cf3c9e19a79aa809be6
- https://gitee.com/yanyutao0402/ChanCMS/issues/ICLP1K
- https://gitee.com/yanyutao0402/ChanCMS/releases/tag/V3.1.3
- https://vuldb.com/?ctiid.317529
- https://vuldb.com/?id.317529
- https://vuldb.com/?submit.619777
- https://gitee.com/yanyutao0402/ChanCMS/issues/ICLP1K
Get alerted when CVE-2025-8133 or the next vulnerability affects your stack