What’s Vulnerable › Vulnerabilities
CVE-2025-8151: HT Mega – Absolute Addons For Elementor <= 2.9.1 - Authenticated (Author+) Path Traversal to Limited Arbitrary CSS File Actions
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-31 · updated 2026-06-17
- Weakness: CWE-22
Description
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 2.9.1 via the 'save_block_css' function. This makes it possible for authenticated attackers, with Author-level access and above, to create CSS files in any directory, and delete CSS files in any directory in a Windows environment.
Affected products
- devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder: before 2.9.2 — fixed in 2.9.2
How to fix
Upgrade to a fixed version: devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.9.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ht-mega-for-elementor/tags/2.9.1/htmega-blocks/includes/classes/Manage_Styles.php#L118
- https://plugins.trac.wordpress.org/changeset/3336533/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6b3e93bf-af5c-4ca3-a531-2d91df880c51?source=cve
Get alerted when CVE-2025-8151 or the next vulnerability affects your stack