What’s Vulnerable › Vulnerabilities
CVE-2025-8217: Inert Malicious script injected into Amazon Q Developer Visual Studio Code (VS Code) Extension
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-506
Description
The Amazon Q Developer Visual Studio Code (VS Code) extension v1.84.0 contains inert, injected code designed to call the Q Developer CLI. The code executes when the extension is launched within the VS Code environment; however the injected code contains a syntax error which prevents it from making a successful API call to the Q Developer CLI. To mitigate this issue, users should upgrade to version v1.85.0. All installations of v1.84.0 should be removed from use.
Affected products
- Amazon Q Developer VS Code Extension: from 1.84.0 before 1.85.0 — fixed in 1.85.0
How to fix
Upgrade to a fixed version: Amazon Q Developer VS Code Extension 1.85.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2025-015/
- https://github.com/aws/aws-toolkit-vscode/releases/tag/amazonq%2Fv1.85.0
- https://github.com/aws/aws-toolkit-vscode/security/advisories/GHSA-7g7f-ff96-5gcw
Get alerted when CVE-2025-8217 or the next vulnerability affects your stack