What’s Vulnerable › Vulnerabilities
CVE-2025-8228: yanyutao0402 ChanCMS getPages server-side request forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-27 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability was found in yanyutao0402 ChanCMS up to 3.1.2. It has been rated as critical. Affected by this issue is the function getPages of the file /cms/collect/getPages. The manipulation of the argument targetUrl leads to server-side request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.3 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- yanyutao0402 ChanCMS: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: yanyutao0402 ChanCMS 3.1.3. Check the vendor advisory for mitigations.
References
- https://gitee.com/yanyutao0402/ChanCMS/issues/ICLP28
- https://gitee.com/yanyutao0402/ChanCMS/releases/tag/V3.1.3
- https://vuldb.com/?ctiid.317816
- https://vuldb.com/?id.317816
- https://vuldb.com/?submit.622171
- https://gitee.com/yanyutao0402/ChanCMS/issues/ICLP28
Get alerted when CVE-2025-8228 or the next vulnerability affects your stack