What’s Vulnerable › Vulnerabilities
CVE-2025-8259: Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.
Affected products
- VaelsysV4: 4.1.0
References
- https://github.com/waiwai24/0101/blob/main/CVEs/Vaelsys/Remote_Code_Execution_in_Vaelsys_V4_Platform.md
- https://vaelsys.github.io/security-advisory/advisories/VSEC_V4_2025_07_0001.html
- https://vuldb.com/submit/616920
- https://vuldb.com/vuln/317847
- https://vuldb.com/vuln/317847/cti
Get alerted when CVE-2025-8259 or the next vulnerability affects your stack