What’s Vulnerable › Vulnerabilities
CVE-2025-8260: Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-327
Description
A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.
Affected products
- VaelsysV4: 4.1.0
References
- https://github.com/waiwai24/0101/blob/main/CVEs/Vaelsys/Unauthorized_Access_Leads_to_Sensitive_Information_Leakage_in_Vaelsys_V4_Platform.md
- https://vaelsys.github.io/security-advisory/advisories/VSEC_V4_2025_07_0002.html
- https://vuldb.com/submit/616922
- https://vuldb.com/vuln/317848
- https://vuldb.com/vuln/317848/cti
Get alerted when CVE-2025-8260 or the next vulnerability affects your stack