What’s Vulnerable › Vulnerabilities
CVE-2025-8264
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-29 · updated 2026-06-17
- Weakness: CWE-89
Description
Versions of the package z-push/z-push-dev before 2.7.6 are vulnerable to SQL Injection due to unparameterized queries in the IMAP backend. An attacker can inject malicious commands by manipulating the username field in basic authentication. This allows the attacker to access and potentially modify or delete sensitive data from a linked third-party database. **Note:** This vulnerability affects Z-Push installations that utilize the IMAP backend and have the IMAP_FROM_SQL_QUERY option configured. Mitigation Change configuration to use the default or LDAP in backend/imap/config.php php define('IMAP_DEFAULTFROM', ''); or php define('IMAP_DEFAULTFROM', 'ldap');
Affected products
- z-push/z-push-dev: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: z-push/z-push-dev 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/Z-Hub/Z-Push/blob/af25a2169a50d6e05a5916d1e8b2b6cd17011c98/src/backend/imap/user_identity.php%23L211C9-L214C25
- https://github.com/Z-Hub/Z-Push/pull/161
- https://github.com/Z-Hub/Z-Push/pull/161/commits/f981d515a35ac4c303959af21dce880a5db02786
- https://security.snyk.io/vuln/SNYK-PHP-ZPUSHZPUSHDEV-10908180
- https://xbow.com/blog/xbow-zpush-sqli/
Get alerted when CVE-2025-8264 or the next vulnerability affects your stack