What’s Vulnerable › Vulnerabilities
CVE-2025-8267
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-918
Description
Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP address ranges. Specifically, the package fails to classify the reserved IP address space 224.0.0.0/4 (Multicast) as invalid. This oversight allows attackers to craft requests targeting these multicast addresses.
Affected products
- ssrfcheck: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: ssrfcheck 1.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lirantal/2976840639df824cb3abe60d13c65e04
- https://github.com/felippe-regazio/ssrfcheck/commit/9507b49fd764f2a1a1d1e3b9ee577b7545e6950e
- https://github.com/felippe-regazio/ssrfcheck/issues/5
- https://security.snyk.io/vuln/SNYK-JS-SSRFCHECK-9510756
Get alerted when CVE-2025-8267 or the next vulnerability affects your stack