What’s Vulnerable › Vulnerabilities
CVE-2025-8279: Missing Authentication for Critical Function in GitLab Language Server
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-28 · updated 2026-06-17
- Weakness: CWE-306
Description
Insufficient input validation within GitLab Language Server 7.6.0 and later before 7.30.0 allows arbitrary GraphQL query execution
Affected products
- GitLab Language Server: from 7.6.0 before 7.30.0 — fixed in 7.30.0
How to fix
Upgrade to a fixed version: GitLab Language Server 7.30.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8279 or the next vulnerability affects your stack