What’s Vulnerable › Vulnerabilities
CVE-2025-8325: Improper Access Control via Gateway API in Multiple WSO2 Products Allows Unauthorized Operations
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-14
- Weakness: CWE-281
Description
The software fails to enforce role-based access controls for certain Gateway API invocations. Users with the 'Internal/Everyone' role can invoke these APIs, bypassing intended permission checks. This same vulnerability also affects Internal Service APIs, potentially exposing them in WSO2 APIM 3.x versions. A malicious actor with a valid user account on a vulnerable deployment can perform sensitive operations against the Gateway REST API regardless of their actual roles or privileges. This could lead to unintended behavior or misuse, particularly in production environments.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.18 — fixed in 4.5.0.18
- WSO2 API Manager: from 3.2.0 before 3.2.0.435; from 3.2.1 before 3.2.1.55; from 4.0.0 before 4.0.0.355; from 4.1.0 before 4.1.0.219; from 4.2.0 before 4.2.0.157; from 4.3.0 before 4.3.0.70 — fixed in 3.2.0.435, 3.2.1.55, 4.0.0.355, 4.1.0.219, 4.2.0.157, 4.3.0.70
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.17 — fixed in 4.5.0.17
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.17 — fixed in 4.5.0.17
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.18; WSO2 API Manager 3.2.0.435, 3.2.1.55, 4.0.0.355, 4.1.0.219; WSO2 Traffic Manager 4.5.0.17; WSO2 Universal Gateway 4.5.0.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-8325 or the next vulnerability affects your stack