What’s Vulnerable › Vulnerabilities

CVE-2025-8402: Nil pointer dereference in bulk import crashes server

Description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to validate import data which allows a system admin to crash the server via the bulk import feature.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.9, 10.8.4, 10.9.4, 9.11.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-8402 or the next vulnerability affects your stack